본문 바로가기
HELLO_WORLD/안드로이드_Android

[지식공유] 안드로이드 API 26 업그레이드 요구사항

by 해피한 김과자블루스웨터 2018. 9. 1.












안드로이드 api 업그레이드 요구사항



안녕하세요. 이번에 앱 업데이트를 하던중 요딴걸 발견 했습니다. 무려 구글이 날린 경고 였죠. 



'2018년 후반부터 API 레벨 대상 지정 요구사항'



뭔소리야 하고 알아봤더니 여러가지로 귀찮은 내용입니다.

심호흡 하시고 후우...



*2018년 하반기에 Google Play는 새 앱과 앱 업데이트 시 최신 Android API 레벨을 대상으로 지정하도록 요구할 것입니다. 2018년 8월에 새 앱에 대해, 그리고 2018년 11월에 기존 앱의 업데이트에 대해 이를 요구할 것입니다. 이는 보안 및 성능에 최적화된 최신 API를 기반으로 앱을 빌드하도록 보장하기 위한 것입니다.


*Google Play는 2019년 8월에 네이티브 라이브러리를 포함한 새 앱과 앱 업데이트에서 32비트 버전 외에 64비트 버전도 제공하도록 요구할 것입니다.


*또한, 2018년 초에 앱의 진위 여부를 더 확실히 확인할 수 있도록 각 APK 상단에 소량의 보안 메타데이터를 추가할 예정입니다. 이러한 변경 사항에 대해 따로 어떤 조치도 취할 필요는 없습니다.



정리 : 


2018년 8월부터 새로운 앱은 target-api : 26 설정해야한다.

2018년 11월부터 기존앱들도 target-api : 26 설정해야한다.

2019년 8월 부터는 64bit 버전까지 요구 한다고 합니다.

2019년 이후: 매년 targetSdkVersion 요구사항이 향상될 것입니다. 새 안드로이드 디저트 출시 이후 1년 이내에 새 앱 및 앱 업데이트에서 해당 API 레벨 이상을 대상으로 지정해야 합니다.



*** 또한 64비트 지원에 따른 변경도 있을예정 기존 32비트 지원은 끊기지 않으며

네이티브 라이브러리를 포함한 앱만 영향을 받습니다.



참고 : 

https://developers-kr.googleblog.com/2018/01/improving-app-security-and-performance-on-google-play.html



댓글0